BoaterEd Store      - Help Support This Forum - Join Today!      Hunting/Fishing Stuff
BoaterEd
Username:
Password:
Save Password


Register

Active Topics | Active Polls | Resources | Members | Online Users | Avatar Legend | Statistics
[ Active Members: 6 | Guests: 113 ]  [ Total: 119 ]  [ Newest Member: Robert Lamkin ]
 All Forums
 Clubs - Organized Clubs, Cruises and Activities
 Silverton Owners
 Windlass malfunction
 New Topic |   Reply to Topic | 
Author Previous Topic: 1984 34c for sale  18,000 or best offer! Topic Next Topic: Best place to tie off boat?  

Kevdon22

RO# 32964

Posted - Jun 26 2012 :  18:47:09  Show Profile  Reply with Quote
Posted this under engines,etc.
Thought someone with a Silverton might know how they installed Windlasses.

Tried my first anchoring exercise of the season yesterday and found that the windlass would not work. I tested it before boat launch and it did work about a month ago. Lucky that my son was on board to launch and retrieve anchor with the clutch loosened.

I checked the circuit breaker in the bilge near the battery and there is voltage on both sides.

Neither the switch at the bridge nor the buttons at the bow do anything.

Is there another breaker near or within the windlass? When I flip the switch there is no voltage drop on the gauge. Also the circuit breaker near the battery does not trip. Did not time to troubleshoot Sunday.

I wonder if there is a breaker in the control system somewhere.

Any thoughts?

The windlass is a horizon express installed on a 1999 Silverton 422 and has never had any repairs yet.

Appreciate any comments.
Kevdon
Forked River,
Barnegat Bay
NJ

Homeport: Forked River, NJ

Caryl-d

RO# 7966

Posted - Jul 20 2012 :  11:22:25  Show Profile  Reply with Quote
I may be late but there should only be one breaker. There should have been a relay solenoid by the breaker that could be the problem. The first area I would check is under the bow in the anchor locker. There should be a buss bar that the windlas connects to. Have someone press the up or down butoon and see if the is power to the bar when pressed. If so the solenoid is good. I have had problems with the connections on the bus bar corroding causing a bad connection. Clean them up and see if that helps. You may have to prick the wires going to the motor from the bus buss bar to confirm a good connection. If it is good then its the motor. I believe Horizon is out of buisness so you may have a hard time finding a replacement motor.

Butch
The Gov of "B" Dock

Homeport: SS3@Penny Bridge Marina Stony Point, NY Go to Top of Page

Caryl-d

RO# 7966

Posted - Jul 20 2012 :  11:28:37  Show Profile  Reply with Quote
Thats what I get for not checking the other section first, glad to see you found the problem
1


Butch
The Gov of "B" Dock

Homeport: SS3@Penny Bridge Marina Stony Point, NY Go to Top of Page
  Previous Topic: 1984 34c for sale  18,000 or best offer! Topic Next Topic: Best place to tie off boat?  
 New Topic |   Reply to Topic | 
Jump To:
BoaterEd © BoaterEd Go To Top Of Page
This page took 0.34 seconds to load
Forum Guidelines and Privacy Notice

    

Boatered.com